Subscribe / Unsubscribe Enewsletters | Login | Register

Pencil Banner

Concerned about OS X fragmentation and security? Don't be

Dan Moren | Jan. 14, 2014
Think platform fragmentation is something only Android users need to worry about? Over at the Sophos blog, Chester Wisniewski thinks Mac users should worry, too. Why? Because with the increasing pace of OS X updates, those who don't or can't update to the latest version of Mac OS may be left vulnerable to security exploits. Wisniewski claims that, "Apple appears to have stopped releasing security updates for OS X 10.6.8, 10.7.5 and 10.8.5."

Calling Mountain Lion "orphaned" is a bit misleading. Every Mac that's capable of running Mountain Lion is also capable of running Mavericks. In that sense, Mavericks provides a full upgrade path for those users.

Lion is a little more difficult: Most Macs running Lion can handle Mavericks — the newest machine that can't is from 2008, and there are only a handful of them. Snow Leopard, for its part, has been relegated to the OS of choice for many legacy machines, and while that shouldn't mean being denied security updates, you have to know what you're getting into when your operating system is five years old and has been superseded by three later updates.

Wisniewski and I are in agreement about one thing: Apple should publicly state what level of support it's providing for older versions of OS X and for how long, especially if it plans to continually release new major updates every year. But while staying up to date with security patches may be a concern, fragmentation on the Mac and fragmentation on Android are still two very different ballgames.

 

Previous Page  1  2 

Sign up for Computerworld eNewsletters.